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Creating Accessible iTunes U Content

Introduction
With iTunes U, students, educators, and the public have anytime, anywhere access 
to a continually growing and comprehensive collection of free educational media that 
includes movies, audio files, and PDFs. By taking the steps to make these media 
files fully accessible, iTunes U content providers will ensure that all students and 
others can fully benefit from these valuable educational resources.

This guide will teach you how to make your iTunes U materials accessible for those 
people who are deaf, hard of hearing, blind or visually impaired. After a brief review 
of accessibility and access technology, you will learn how to add captions, foreign-
language subtitles and audio descriptions to multimedia playable in iTunes and 
QuickTime Player, as well as mobile devices such as iPhone and iPod. You’ll also 
learn how to create accessible PDF documents to support the multimedia on your 
iTunes U site.

Part 1:  Understanding Accessibility and iTunes Multimedia

1.1: Overview of Terms and Concepts

Before learning how to create accessible iTunes materials, it will be helpful to define 
terms and concepts relevant to accessible multimedia in iTunes.

Captions

Captions were originally invented nearly 40 years ago to help deaf and hard-of-
hearing people understand television, but they are in fact useful to everyone. 
Captions are always written in the same language as the audio. They not only render 
the main audio track (known as program audio) as text on the screen, they also 
indicate important non-speech information, such as sound effects, music and 
laughter. In some countries they are called subtitles, which is not the same as 
foreign-language subtitles (see below). 

Captions are either closed or open. Closed captions are transmitted as data along 
with the video but are not visible until the user elects to turn them on, usually by 
invoking an on-screen control or menu selection. Open captions are always visible; 
they have been merged with the video track and cannot be turned off. The rules and 
regulations related to closed captions can be found on the Federal Communications 
Commission’s website.

SCC captions

The SCC (Scenarist Closed Caption) file format is a human-readable representation 
of the actual line-21 closed-caption data carried in the NTSC broadcast signal.  Data 
in the SCC format are closed captions that can be embedded into iTunes-compatible 
video or audio files, and can be decoded by QuickTime Player (7.1.6 or greater), 
iTunes (7.4 or greater), iPhone, iPod touch and iPod nano. These devices offer a 
menu choice or an on-screen switch to toggle the caption text on and off.  SCC 
captions cannot be styled by the author; that is, their display characteristics (font 
face and size, background color, background opacity, etc.) are determined by a 
combination of the caption data and the playback device.

file:///Users/geoff_freed/Desktop/NCAM/SP/Apple/iTunes_U/final_from_patterson/Federal Communications Commision's website
file:///Users/geoff_freed/Desktop/NCAM/SP/Apple/iTunes_U/final_from_patterson/Federal Communications Commision's website
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Below is an image of SCC captions being played in iTunes. You can also watch a 
brief video clip with SCC captions.

QTText captions

QTText is a text format from Apple used primarily for creating and displaying captions 
and foreign-language subtitles. They can be open or closed (see Part 1.5 for 
important information), and nearly all display characteristics of QTText captions can 
be specified by the author: font face, size, weight, color, etc. The caption region (the 
box in which the captions are displayed) can have a solid background, a translucent 
background or a transparent background, and can be placed directly over the video 
region or adjacent to the edges of the video region. In most cases, QTText captions 
integrated into iTunes multimedia will be open. Below is an image showing one 
example of QTText captions. You can also view a brief video clip with QTText 
captions.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2086080798?i=2050997569
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2086080798?i=2050997569
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083381266?i=1884927864
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083381266?i=1884927864
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Foreign-language subtitles

Foreign-language subtitles are a translation of dialog or narration into words on the 
screen. Unlike captions, subtitles are not strictly intended for use by deaf or hard-of-
hearing viewers and so do not contain non-speech elements. In iTunes multimedia, 
subtitles can be created using QTText. QuickTime Player, iTunes and iPhone also 
have a built-in menu to toggle between multiple subtitle tracks when the text has 
been encoded in a special manner; see Part 3.2 for details.

Audio descriptions

Audio descriptions (also known as video descriptions or simply descriptions) make 
visual media accessible to people who are blind or visually impaired by providing 
descriptive narration of key visual elements. These elements include actions, 
costumes, gestures, scene changes or any other important visual information that 
someone who cannot see the screen might ordinarily miss. Descriptions are usually 
timed and recorded to fit into natural pauses in the program-audio track. Watch a 
brief video clip with audio descriptions.

As with captions, descriptions can be open or closed. Open descriptions are 
merged with the program-audio track and cannot be turned off by the viewer. In most 
cases, descriptions integrated into iTunes multimedia will be open. Closed 
descriptions can be recorded as a separate track containing descriptions only, 
timed to play at specific spots in the timeline and played in parallel with the program-
audio track. Authors may also include two program-audio tracks within a single 
movie—one with descriptions and one without. See Part 1.5 for important information 
about accessing closed descriptions in iTunes U multimedia. 

Screen reader

A screen reader locates information seen on the computer screen and vocalizes it 
using speech synthesis software. A screen reader application is purchased 
separately and added to a computer to enable it to be used by people who are 
blind and visually impaired. Mac OS X comes with a built-in screen reader, 
VoiceOver; Windows screen readers are third-party devices that must be purchased 
and installed by the user. Screen readers are available for desktop and laptop 
computers as well as certain mobile devices, including iPhone 3GS. Similarly, both 
iPod nano and iPod shuffle make use of speech synthesis technology (via spoken 
menus and VoiceOver, respectively) to navigate menus and playlists without sight. 

1.2: Benefits of captions and audio descriptions

Both captions and audio descriptions are useful to a wide array of users in addition 
to their originally intended audiences. Groups who benefit include, but are not limited 
to, the following:

• Anyone in a noisy environment, or an environment where loud volume is not 
appropriate. Gyms, bars and restaurants regularly employ captions as a way for 
patrons to watch television while in those establishments.

• People learning to read or learning English as a second language. Research has 
shown that captions help reinforce vocabulary and language.

• Students grappling with difficult materials or concepts. Audio descriptions can be 
used to give supplemental information about what is on screen—the structure of 
lengthy mathematical equations or the intricacies of a painting, for example.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084757097?i=1688519967
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• The aging population. As a large portion of the population grows older, both 
captions and audio descriptions could become important for people who develop 
sensory disabilities that accompany the aging process.

• Researchers. Captions can provide a powerful search capability, allowing users to 
search the caption text to locate a specific video or an exact point in a video.

1.3: Accessible PDF documentation

iTunes U allows you to upload not just audio and video materials; it also supports 
PDF documentation. PDF is a popular format from Adobe that preserves the fonts, 
images, graphics and layout of nearly any source document. This ensures that users 
will see the finished document exactly as the author intended. 

PDFs can be created so that people with disabilities can access them. In order for 
PDFs to be accessible, they need to be created using properly structured tags, 
appropriate alternative information where necessary (e.g., image tags must contain 
alt text), and the tags must reflect the proper reading order. If a document is created 
with this in mind, it can be successfully accessed using a screen reader or other 
assistive technology.

Screen-reader users are especially affected by the way in which the PDF is created, 
so it is crucial that PDFs be authored to be accessible by everyone. A PDF that 
hasn’t been made accessible can be difficult or even impossible for a blind or visually 
impaired user to navigate. A variety of tools and techniques exist to create accessible 
PDFs, but authors must be careful to observe the approaches outlined in Part 5 to 
ensure that the document is usable by everyone.

1.4: Tools for creating accessible iTunes materials

If you’re new to iTunes U, start by visiting the iTunes U site for general information 
and links to discussion forums and support materials. “Creating Your iTunes U Site” 
from Apple Education will give you basic information about how to build your first 
iTunes U site. If you aren’t sure what video and audio formats are compatible with 
iTunes U, or have never created video or audio clips before, read “Creating Content 
for iPod + iTunes” from Apple Education before proceeding any further. 

Below is a basic list of applications and support materials you’ll need to make your 
iTunes U materials accessible.

Multimedia:

• Captioning software (see Part 2, Table 1)

• QuickTime Player Pro 7.X  

• A text editor (such as TextEdit or NotePad)

• Audio-recording software, such as QuickTime,   GarageBand  ,   Audacity  ,   Logic   or   
Sound Forge

http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/logicstudio/logicpro/
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://audacity.sourceforge.net/
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/ilife/garageband/
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/quicktime/
http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
http://images.apple.com/support/itunes_u/docs/iTunes_Create_U_Guide.pdf
http://www.apple.com/education/mobile-learning/
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PDF:

• Adobe Acrobat 9 Pro  

• A screen reader such as Jaws, Window-Eyes or VoiceOver

Other software may be necessary for certain procedures (for example, adding closed 
subtitles for playback on iPhone or adding wired sprites for toggling captions or 
descriptions on and off from within QuickTime and iTunes). These applications are 
discussed in the documentation.

Note: Using wired sprites. Wired sprites are QuickTime tracks that add interactivity to 
a presentation. For accessibility purposes, wired sprites can be used for turning 
audio descriptions or QTText captions on and off. The process of integrating them 
into a multimedia presentation is described in Appendix 1. If you’ve never seen them 
before, watch a sample video containing wired sprites.

The use of wired sprites is included in this document for the sake of completeness, 
but they may not be appropriate for all situations. It is important to note that wired 
sprites can be operated only in QuickTime Player or iTunes. They cannot currently 
be used on iPhone or iPod. If you choose to put movies containing wired sprites in 
iTunes U, therefore, you should make it clear to the user that the sprites can only be 
operated on specific players.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084821080?i=1842088322
http://www.adobe.com/products/acrobat/
http://www.adobe.com/products/acrobat/
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Part 2:  Creating Captions for iTunes Multimedia
Writing captions is not necessarily a difficult task, but it does require some 
forethought and planning. This section will provide you with information on choosing 
and implementing a caption format, budgeting time and when to consider having an 
outside vendor create the caption files for you. 

Captions should be added to a presentation once the video and audio elements have 
been completed. Waiting to author captions until the end of the production process 
will ensure that they accurately reflect the program audio. If you must re-edit the 
video or audio after the captions have been created, you may have to re-edit the 
captions as well. 

iTunes U multimedia supports two caption formats: SCC and QTText. Both are 
explained in detail below; see Part 1.1 for a general discussion about the differences 
between the two. Broadly speaking, the SCC format is best for implementing closed 
captions, and QTText is best for open captions and foreign-language subtitles. 
QTText can also be used to display closed captions, but you must create a wired 
sprite to turn the captions on and off. See Part 1.5 for more information about wired 
sprites. 

In many ways, closed captions offer the best experience for all viewers because they 
are hidden unless explicitly revealed by the user. Open captions are suitable in 
situations where the author needs control over specific characteristics of the text 
(color or font face, for example), or when the most effective option is to simply 
always have the captions visible. Provided the text accurately reflects the audio and 
is clearly displayed, however, both closed and open captions work equally well to 
make multimedia accessible to deaf and hard-of-hearing viewers.

When developing a workflow for a project, remember to include enough time to write 
captions and integrate them into the final presentation. How much time is required 
will, of course, vary with each project. For example, a 10-minute documentary-style 
clip will probably take less time to caption than a clip of the same length but with 
multiple speakers and frequent shot changes. How much experience the author has 
in writing captions will also affect the timeline: someone new to the process may take 
several hours more to create the data than someone familiar with the process. To 
save production time, select and learn to use captioning software before you 
actually need to caption your multimedia. 

Before creating your own captions, learn about iTunes-compatible file formats by 
reading “Creating Content for iPod + iTunes” from Apple Education. Captions can be 
created using a number of different software packages. The table below shows 
several currently available applications. 

http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
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Table 1: Caption-creation software

Name   OS   Cost   Media formats   Output

Annotation Edit Mac OS X $300; 
free demo

MOV, MP4, M4V, 
others

SCC, QTText, others

CapScribe  Mac OS X Free MOV, MP4, AVI QTText, others

Hi-Caption  Windows Varies AVI, MOV, others QTText, RealText, 
SAMI, others

MAGpie  Mac OS X, 
Windows

Free MOV, AVI, WMV, 
RM

QTText, RealText, 
SAMI, DFXP, plain 
text

MacCaption, 
CaptionMaker

Mac OS X, 
Windows

Varies Tape, MOV, MP4, 
others

Broadcast formats 
plus QTText, SCC, 
others

MovCaptioner Mac OS X $25 MOV, MP4, M4V, 
others

SRT, QTText, others

Subtitle Workshop Windows Free AVI, WMV, others SRT, QTText, others

2.1: Captioning method

Providing synchronized captions is significantly different from merely providing a text 
transcript of the audio portion of the presentation. (However, a text transcript is 
always recommended in addition to captions. Transcripts provide an easy way to 
scan a video’s script or to search for particular terms. In iTunes, they can be 
uploaded as accessible PDF documents or included as metadata that travels with 
the clip itself. See below for details.)There are a number of applications you can use 
to create captions; several are shown in Table 1, above. Specific caption-creation 
processes will vary depending on the software used; however, the general workflow 
can be described as follows.

Enter caption text into the editor

Caption text can be entered by transcribing directly into the editor or, in many cases, 
by importing an electronic script. The latter is generally more efficient than the 
former, but this may vary depending on the application.

Edit and break text into captions

Once you have entered text into the caption editor, you can edit as necessary, 
correct spelling errors and divide or combine blocks of text to create smaller or larger 
captions. Normally, each caption will contain one, two or three rows of text.

Time the captions

Once the text has been edited and formatted, you’ll assign a timecode to each 
caption that indicates when it will appear or disappear from the screen. How you do 
so will depend on the software you’re using, but it’s generally as simple as pressing 
a button on the keyboard or clicking one on-screen. In most cases you’ll find that one 
caption will follow another without pause, but you will also have the option to erase 
the caption display when there is a break in the narration or dialog.

http://www.urusoft.net/products.php?cat=sw&lang=1
http://www.synchrimedia.com/
http://www.ccaption.com/#http://www.ccaption.com/
http://www.ccaption.com/#http://www.ccaption.com/
http://ncam.wgbh.org/webaccess/magpie/
http://www.hisoftware.com/
http://www.capscribe.ca/
http://www.zeitanker.com/
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Review your work

Misspelled or poorly edited and timed captions will only make it harder for the viewer 
to keep up with what’s happening on-screen, so accuracy in captioning is 
paramount. In most caption-editing software, you’ll be able to make changes to both 
text and timing as you spot errors. If possible, have someone else review your work 
when you are done.

Export a caption file and add the captions to the video

When you’re satisfied with your work, your captioning software will allow you to 
export the captions in various formats. In iTunes, you can use either QTText or SCC. 
See the next section for details on adding the captions to the video itself.

Create a transcript

Once you’re finished captioning your video, create a transcript and upload that to 
iTunes U along with the video. Transcripts are useful for everyone: before taking the 
time to download a video, a user can scan the transcript to see if the video is worth 
retrieving. They’re also searchable, can be printed or e-mailed and can be used as a 
reference tool.

Transcripts can be supplied as accessible PDFs; be sure to read Part 5 before you 
upload the file. They can also be added as metadata using the Lyrics pane; read 
“Creating Content for iPod + iTunes” to learn how to paste text into the Lyrics pane 
for this purpose. 

2.2: Appearance and position of captions on the screen

What captions look like in iTunes multimedia will depend on the format you choose. 
SCC closed captions look very similar to NTSC broadcast closed captions, and 
characteristics such as font face, size or background are determined by the device 
decoding the caption data. They are always positioned over the video region, and 
the author can choose to place them on the screen in various locations (e.g., left, 
right, center, top, bottom) to indicate who is speaking or to avoid covering important 
on-screen graphics or action. Finally, they can display a maximum of 32 characters 
per caption row. QuickTime Player, iTunes, iPhone and iPod nano can decode SCC 
captions; all offer a convenient built-in interface to turn the captions on and off (see 
Appendix 2). Here’s a picture of SCC captions playing in iTunes:

http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
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If you want complete control over font characteristics, QTText captions can be 
created in nearly any font (keep in mind that some fonts are more readable as 
captions than others), color, weight or size. In most cases, however, authors use a 
light-colored font over an opaque (black) background, as demonstrated in the 
images below.
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The position of the caption region (the box in which the captions are placed) can also 
vary. Most authors will place the caption region adjacent to the bottom edge of the 
video region, as shown in the images above. However, QTText captions can also be 
positioned in an opaque region directly over the video, as shown below.

They can also be placed over the video in a translucent region, which allows viewers 
to see a bit of the movie behind the caption background...
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...or in a transparent region over the video, which makes the captions appear to float 
over the video, as shown below.

Finally, the placement of QTText captions within the caption region is variable. In 
many cases, authors will place the captions in the center of the region, as seen here.
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You can also move the captions to one side to indicate who is speaking:

Or you can leave them in the center and simply identify who is speaking:

In most cases, QTText captions integrated into iTunes multimedia are open—that is, 
they are merged with the video track and cannot be turned off. If you want QTText 
captions to be closed, you’ll need to create a wired sprite to add a custom caption-
toggle interface to the movie (see Appendix 1 as well as Part 1.5). Wired sprites can 
be operated only when the movie is played using QuickTime or iTunes. A movie with 
wired sprites cannot be used on iPod.
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2.3: Considerations for writing captions 

Captions are not difficult to create, but caption writing can be time-consuming, 
especially for those new to the process. For example, someone with experience 
might be able to write, edit, review and output captions for a 10-minute clip in 
approximately 45 minutes, whereas the same clip captioned by a new user might 
take 2 hours or more to create. The speed at which a clip can be captioned will vary 
depending on a number of factors, such as the author’s typing speed and command 
of English. An electronic script or transcript of the program audio, which is usually 
prepared as part of the general production process, is a valuable time-saver because 
it can be imported into most captioning applications, thereby eliminating the need to 
transcribe the audio from scratch.

Someone with excellent writing, spelling and listening skills can write captions. 
Captioners should have adequate access to reference and support materials 
(dictionaries, textbooks, the Web, etc.) in order to ensure that the captions are as 
accurate as possible. Ideally, the captions should be given a final review by someone 
other than the original writer.

When the workload is greater than in-house staff can support, it would be wise to 
consider sending the multimedia to a vendor who can create captions in a timely 
manner. Rates for this service will vary widely depending on the length of the 
material, formats required, turnaround time, etc. A short list of major vendors can be 
found in Appendix 4.

2.4: Creating SCC closed captions 

As discussed earlier, a main advantage of SCC captions is that they make use of 
built-in caption controls in QuickTime Player, iTunes, iPhone and iPod nano, giving 
users easy access to the captions at all times. Currently, SCC caption files can be 
exported directly from zeitAnker’s AnnotationEdit, CPC’s CaptionMaker and 
MacCaption. You can also use free software such as MAGpie to write the initial 
QTText caption files, then use Subtitle Workshop to convert the files to SRT. The 
SRT files can be then converted to SCC using free command-line tools. 
MovCaptioner or Subtitle Workshop will also create SRT caption files, which can 
then be converted to SCC. Check Table 1, above, for details on these and other 
caption-authoring applications. 

Once you have an SCC caption file, you’ll add it to the movie using either QuickTime 
or Compressor (a component of Final Cut Studio), as described in Parts 2.5 and 2.6, 
respectively.

http://www.apple.com/finalcutstudio/
http://www.apple.com/finalcutstudio/compressor/
http://www.apple.com/quicktime/
http://www.urusoft.net/products.php?cat=sw&lang=1
http://www.synchrimedia.com/
http://www.geocities.com/mcpoodle43/SCC_TOOLS/DOCS/SCC_TOOLS.HTML
http://www.urusoft.net/products.php?cat=sw&lang=1
http://ncam.wgbh.org/webaccess/magpie/index.html
http://www.cpcweb.com/nle/
http://www.cpcweb.com/nle/
http://www.zeitanker.com/content/tools/zeitanker_tools/zeitanker_annotation_edit/
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2.5: Using QuickTime to add SCC captions to video clips 

Follow the instructions below to use QuickTime to create SCC-captioned movies 
playable on desktop or mobile players.

1 Open the uncaptioned movie using QuickTime.

2 Choose File > Export, then choose Movie to iPod. Close the movie window when the 
export is finished.

3 Open the exported movie in QuickTime. Set this window aside.

4 Open the SCC file in a new QuickTime Player window. You should see the captions 
displayed over a white region, as shown in the picture below. If you don’t see 
captions, make sure the captions are turned on by choosing View > Show Closed 
Captioning.
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The default size of the SCC track is 640 x 480. If this isn’t the size of your source 
video, you’ll need to scale the track. Choose Window > Show Movie Properties. In 
the tracks list, click Closed Caption Track, then click the Visual Settings button. In the 
Scaled Size fields, enter the height and width to match that of your source video. 
Depending on the size of the source, you may need to uncheck the Preserve Aspect 
Ratio box. Below is an example.

Close the Movie Properties window when you are done.

5 Select (Edit > Select All) and copy (Edit > Copy) the entire SCC caption track.

6 Switch to the uncaptioned M4V movie. Make sure the playhead is positioned at the 
beginning of the movie, then choose Edit > Add to Movie.

7 Play the movie. If you don’t see captions, make sure the captions are turned on by 
choosing View > Show Closed Captioning. Below is an image showing SCC captions 
playing in QuickTime Player.
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8 Move the playhead to the beginning of the movie, choose File > Save, and save the 
file as a self-contained movie. (It will be saved with the MOV file extension, but it will 
still be playable on iPhone or iPod.)

Your SCC closed-captioned movie is now ready to be uploaded to iTunes U. 

2.6: Using Compressor to add SCC captions to video clips

Compressor is a component of Final Cut Studio. If you’re already using Final Cut 
Studio to prepare your movies for iTunes, you will find it very convenient to add SCC 
caption files with Compressor. Note that Compressor does not create SCC 
captions. Instead, it takes existing SCC files and encodes them into movies. See 
Part 2.4 to learn about creating SCC files, then follow the instructions below to add 
them to your movies.

1 Open the uncaptioned video file(s) in Compressor.

2 In the Batch window, apply the appropriate output settings (e.g., H.264 for iPod video 
and iPhone).

3 Click the job to which you want to add captions.

4 In the Inspector window, click the Additional Information tab, as shown below.

5 Click the Choose button and browse to the SCC file.
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6 Click the Submit button in the Batch window to start the compression.

When the compression is finished, your SCC closed-captioned movie will be ready to 
upload to iTunes U. 

2.7: Adding QTText captions to video clips

The instructions below will show you how to merge QTText captions with the source 
video, creating an open-captioned movie. If you want your QTText-captioned 
presentation to play on all devices, open captions are currently the best option. If you 
want closed QTText captions, you’ll need to add wired sprites to toggle the captions 
on and off, but bear in mind that these controls can only be used in QuickTime and 
iTunes (see Part 1.5). See Appendix 1 to learn about using wired sprites. 

1 Open the QTText file in QuickTime Player. The file opens as a caption track, as 
shown below.

2 Select (Edit > Select All) and copy (Edit > Copy) the entire track.

3 Open the original (uncaptioned) video in a new QuickTime window.

4 Place the playhead at the beginning of the movie, then choose Edit > Add to Movie. 
The caption track appears at the top of the video region, as shown below.

5 Open Window > Show Movie Properties. Double-click Text Track, enter a more 
descriptive name (e.g., captions) and press Return.
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6 Click the Visual Settings button.

7 Reposition the caption region: in the Offset area, enter the new position. The first 
entry is the X (horizontal) position; the second entry is the Y (vertical) position. For 
example, if the source video is 400w x 300h, and you want the top of the caption 
region to be positioned at the bottom edge of the video region, enter an offset of 
0 x 300, as shown below.
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8 Close the Movie Properties window.

9 Move the playhead to the beginning of the movie, choose File > Save As, and save 
the file as a self-contained movie. 

10 Choose File > Export and export as Movie to QuickTime Movie. This will create an 
open-captioned movie—the text track will be combined with the video track so the 
captions cannot be turned off. 

11 Open the exported movie in a new QuickTime window, choose File > Export, then 
choose Movie to iPod. 

Your QTText open-captioned movie is ready to be uploaded to iTunes U.

2.8: Displaying QTText captions over a transparent background

Instead of placing the caption region below the video region, as described above, it 
is possible to display captions directly over the video region using a transparent 
background. This can be useful for saving space on the screen, for example, since 
placing the caption region outside the video region can enlarge the size of the 
presentation as a whole. 

To embed transparent-background captions, first create a QTText caption file 
(described in Part 2.3). You must then add QuickTime descriptors to the header (the 
bracketed information at the top of the caption file), as detailed below. 

1 Open the QTText file in a text editor, such as TextEdit or Notepad. 

2 In the header, add {keyedText:on}. This will create the transparent caption region.

3 To improve the legibility of the text, add a drop shadow to the captions by adding 
{dropShadow:on} to the header. To adjust the characteristics of the drop shadow, use 
{dropShadowOffset:X,Y}, where X specifies the number of pixels to offset the shadow 
to the right, and Y specifies the number of pixels to offset the shadow down. Values of 
1,1 are often sufficient. 

4 Adjust the height of the caption region by changing {height=X} in the header, where X 
represents the height of the region in pixels. Depending on the font size you’re using, 
a height specification of 40–80 is generally sufficient. If your header doesn’t have a 
{height} descriptor, add it now.

5 Specify the color of the text by adding {textColor:R,G,B} to the header, where R=red, 
G=green and B=blue. Each value can range from 0–65535.

6 Smooth the edges of the text by adding {anti-alias:on}.

http://www.apple.com/quicktime/tutorials/textdescriptors.html
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7 Embed the track as described in Part 2.7. When offsetting the caption track, position 
the caption region near the bottom edge of the video region, as shown below.

Read about QuickTime descriptors to learn more about what you can do with QTText 
tracks.

2.9: Displaying QTText captions over a translucent background 

To embed translucent-background captions in your movie, first create a QTText 
caption file (described in Part 2.3), then follow the steps below.

1 Open a text editor, such as TextEdit, and create a caption-background track by 
entering the following text:

{QTtext}{timescale:100}{width:400}{height:57}

[00:00:00.00]

[00:00:36.20]

The last timecode shown above ([00:00:36.20]) should be altered to represent the 
entire length of your movie. Also change the {width} descriptor to match the width of 
your movie, and the {height} descriptor to accommodate the maximum number of 
rows in a caption. Depending on the font size, a height specification of 40–80 is 
usually sufficient. Do not enter caption text, or any other text, in this file. 

2 Save the file with the extension .txt (e.g., mask.txt). Quit the text editor and then open 
this .txt file in QuickTime. This track will become the background for the captions.

http://www.apple.com/quicktime/tutorials/textdescriptors.html


Creating Accessible iTunes U Content 23

3 Embed this background track into the original movie, as described in steps 2-7 of Part 
2.7. Note that the background track will appear solid black, positioned at the top of 
the video region, as shown in the image below.

4 Choose Window > Show Movie Properties. Double-click Text Track, type a more 
descriptive name (e.g., mask) and press Return. 

5 Click the Visual Settings button.

6 From the Transparency pop-up menu, choose Blend. Move the Transparency Level 
slider left or right to adjust the transparency of the background. Below is an image 
showing the slider at approximately 30% transparency.
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7 Reposition the mask region: in the Offset area, enter the new position. The first entry 
is the X (horizontal) position; the second entry is the Y (vertical) position. Position the 
mask region so the bottom edge just touches the bottom edge of the video region. 

8 Close the Movie Properties window, set the movie aside but do not close the player 
window.

9 Open the QTText caption file in a text editor and add QuickTime descriptors as 
discussed in steps 1-6 in Part 2.8. (You may find that it isn’t necessary to include 
{dropShadow} when embedding translucent captions.) Close the text editor when 
you’re finished.

10 Open the QTText caption file in a new QuickTime window. Select (Edit > Select All) 
and copy (Edit > Copy) the entire track.

11 Click the movie that contains the mask track. Embed the caption track as described in 
Part 2.7. When offsetting the caption track, make sure all the captions fit inside the 
mask, as shown in the image below. If you find that the captions don’t fit properly, 
adjust the {height} in the caption file’s header. 

2.10: Adding SCC captions to audio clips

When adding SCC captions to an audio-only clip you must include a video track for 
the captions to be visible. This video track can be a static image (a university logo, 
for example) layered in the movie so it appears behind the captions. Here’s how it’s 
done.

1 Create SCC captions as described in Part 2.4.

2 Open the original (uncaptioned) audio file in a QuickTime window. Choose File > 
Export and export it as Movie to iPod, and close the window.

3 Open the exported audio file in QuickTime and set this window aside.
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4 Open the SCC file in a new QuickTime Player window. You should see the captions 
displayed over a white region, as shown in the picture below. If you don’t see 
captions, make sure the captions are turned on by choosing View > Show Closed 
Captioning.

The default size of the SCC region is 640 x 480. You can scale this to a smaller size, 
such as 320 x 240, but anything smaller may decrease the readability of the caption 
text. To scale the region, choose Window > Show Movie Properties. In the tracks list, 
click Closed Caption Track, then click the Visual Settings button. In the Scaled Size 
fields, enter the new height and width. Close the Movie Properties window when 
you’re finished.

5 Select (Edit > Select All) and copy (Edit > Copy) the entire track.

6 Switch to the uncaptioned audio file. Make sure the playhead is positioned at the 
beginning of the movie, then choose Edit > Add to Movie.

7 Play the movie. If you don’t see captions, make sure the captions are turned on by 
choosing View > Show Closed Captioning. Set this window aside.

8 Open the image you want to use as a background in a new QuickTime window. 
Choose File > Export, then choose Movie to iPod.

9 Open the exported image in QuickTime. Select (Edit > Select All) and copy (Edit > 
Copy) the entire track.

10 Switch to the captioned audio track. Make sure the playhead is at the beginning of 
the movie, then choose Edit > Add to Selection & Scale.

11 Drag the playhead to a point in the movie where captions should appear and choose 
View > Show Closed Captioning (you won’t see captions at this point, however).

12 Choose Window > Show Movie Properties.

13 Click Closed Caption Track, then the Visual Settings button.
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14 Next to the Layer edit field, click the arrows until you see captions appear in the 
player window (you should only have to move one or two layers). You’ll see 
something similar to the images below.

15 Close the Movie Properties window.

16 Play the movie. You should see SCC captions playing over the background image 
you chose. 

17 Move the playhead to the beginning of the movie, choose File > Save As, and save 
the file as a self-contained movie. Note that it will be saved with the MOV file 
extension, but it will still be playable on iPhone or iPod.

Your SCC-captioned audio clip is now ready to be uploaded to iTunes U. Watch a 
sample SCC-captioned audio clip.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083381246?i=2006531385
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083381246?i=2006531385
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2.11: Adding QTText captions to audio clips 

The instructions below will show you how to merge QTText captions with the source 
audio file, creating an open-captioned audio clip. If you want your QTText-captioned 
presentation to play on all devices, open captions are currently the best option. If you 
want closed QTText captions, you’ll need to add wired sprites to toggle the captions 
on and off, but bear in mind that these controls can only be used in QuickTime and 
iTunes (see Part 1.5). See Appendix 1 to learn about using wired sprites.

An important point to note is that you must include a video track in order for the 
captions to be visible. If no video track is present, the captions will not survive the 
export process described below. This video track can be a static image (a university 
logo, for example) that is visible behind the caption layer, or it can be an image 
scaled to a small size and layered in the movie so it is essentially invisible. The 
example below illustrates the latter.

1 Write the captions and export a QTText file (see Part 2.3). 

2 Open the original (uncaptioned) audio clip in a QuickTime window and set this 
window aside.

3 Open the QTText file in a separate QuickTime window.

4 Select (Edit > Select All) and copy (Edit > Copy) the entire track.

5 Switch to the uncaptioned audio file. Make sure the playhead is positioned at the 
beginning of the movie, then choose Edit > Add to Movie.

6 Play the audio file; you should see captions over a black region, as shown below. Set 
this window aside.

7 Open an image in a new QuickTime window. The content doesn’t matter because it 
will become invisible later. 

8 Chose Window > Show Movie Properties. Click Video Track in the track list and then 
click the Visual Settings button.
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9 Just below the Scaled Size fields, uncheck Preserve Aspect Ratio. In the Scaled Size 
fields, replace the width to match the width of the captioned audio clip, and enter the 
height as 1. Below is an example.

You’ll wind up with a visible region that is only one pixel in height, similar to the one 
below.

10 Close the Show Movie Properties window.

11 Select (Edit > Select All) and copy (Edit > Copy) the entire track.

12 Switch to the player containing the captioned audio clip. Make sure the playhead is 
positioned at the beginning of the clip, then choose Edit > Add to Selection & Scale. 
You should see the image appear at the top of the caption region.

13 Choose Window > Show Movie Properties and click Video Track in the track list, then 
click the Visual Settings button. 
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14 Next to the Layer field, click arrow buttons until you see the image disappear from the 
player window. (It’s not actually disappearing; it’s simply moving behind the caption 
layer.) You should only have to move one or two layers.

15 Move the playhead to the beginning of the movie, choose File > Save As and save 
the file as a self-contained movie. 

16 Choose File > Export and export as Movie to QuickTime Movie. This will combine the 
tracks and create an open-captioned audio clip. 

17 Open the exported movie in QuickTime, choose File > Export, then choose Movie to 
iPod. 

Your QTText open-captioned audio clip is ready to be uploaded to iTunes U. Watch a 
sample QTText-captioned audio clip.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083349866?i=1889003114
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083349866?i=1889003114
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Part 3:  Adding Foreign-Language Subtitles to iTunes 
Multimedia
Foreign-language subtitles will make your iTunes multimedia more versatile and 
allow you to expand the reach of your materials. In many cases, you’ll find that 
QTText tracks are adequate for subtitles. Resist the temptation to create subtitles 
using SCC tracks. If you use SCC tracks for subtitles, you’ll confuse your audience: 
deaf viewers will expect to see captions when they activate the caption toggle, not 
foreign-language subtitles. You’ll also lose the ability to include both closed captions 
and subtitles in your movie.

3.1: Adding QTText subtitles to iTunes multimedia

The steps for integrating QTText subtitles into your video are identical to those for 
captions. See Part 2, Table 1, to learn which captioning applications create QTText 
files. Once you’ve written and exported the text files, follow the directions in Parts 
2.7, 2.8 or 2.9 for adding the subtitles to your video, depending on the style you want 
to use. In the Show Movie Properties window, be sure to name the text tracks 
logically (e.g., French, German, Italian, etc.) so you can easily identify them.

Your movie can accommodate multiple text tracks, but this will require the use of 
wired sprites to toggle each track on and off. As discussed in Part 1.5, these sprites 
can only be used in QuickTime Player and iTunes, not iPhone or iPod. See Appendix 
1 for for instructions on adding wired sprites. 

3.2: Adding closed subtitles to iTunes multimedia

Movies in the M4V format can carry closed subtitle tracks tagged with special 
metadata that allows them to be recognized and decoded by QuickTime Player, 
iTunes, iPhone and iPod touch. These devices give users access to the closed 
subtitles through menus or on-screen controls. This subtitle format has some 
limitations to keep in mind should you choose to implement it: the text can’t be 
styled, and the placement of the subtitles within the player varies depending on the 
playback device (iPhone and iPod touch place them at the bottom of the screen; 
iTunes and QuickTime place them at the top). To see what they look like, watch a 
sample clip with closed foreign-language subtitles.

You’ll need to use several different tools to integrate the closed-subtitle data into your 
movie. A Windows computer is required for some processes, and you should be 
comfortable using the command-prompt window. 

Before beginning, download and install the following software:

• MP4Box   (Windows only). For simplicity, install it in the same directory as the source 
media and subtitle files.

• Dumpster   (Windows). Mac users can download QuickTime Movie Atom Dumpster.

• Captioning software that creates SubRip (SRT) files (see Part 2, Table 1). You can 
also use MAGpie to write the initial QTText subtitle files and Subtitle Workshop to 
convert these files to SRT. 

http://www.urusoft.net/products.php?cat=sw&lang=1
http://ncam.wgbh.org/webaccess/magpie/index.html
http://developer.apple.com/quicktime/quicktimeintro/tools/
http://developer.apple.com/quicktime/quicktimeintro/tools/
http://www.videohelp.com/tools/mp4box
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084233176?i=1362085531
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084233176?i=1362085531
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Once the software is installed, begin by creating the subtitle file.

1 Write the subtitles. The process is similar to the captioning method described in Part 
2.3. Do not apply any styles (color, size, font type, italics, etc.).

2 Export the file as SRT. If you’re using MAGpie, first export the file as QTText, then 
open this file in Subtitle Workshop and save it as an SRT file.

3 On a Windows computer, copy the SRT file into the directory containing MP4Box.exe.

4 Repeat this process for each track of subtitles.

Next, convert the source video to M4V. 

1 Open the movie in QuickTime.

2 Choose File > Export and export as Movie to iPod.

3 Copy the exported movie to the same directory as MP4Box.exe.

Now convert the SRT files to the TTXT format.

1 Open a command-prompt window and change to the directory that contains 
MP4Box.exe.

2 Convert the SRT files to TTXT files by typing (no quotes) “mp4box -ttxt filename.srt”, 
where “filename.srt” is the SRT subtitle file you want to convert.

3 Repeat for each SRT file.

Next, integrate each TTXT file into the source M4V.

1 At the command prompt, type (no quotes) “mp4box -add 
filename.ttxt:lang=threeDigitLanguageCode targetMovieName.m4v”, where 
“filename.ttxt” is the name of the TTXT file you created in the previous step; 
“threeDigitLanguageCode” is the three-digit ISO code representing the track’s 
language; and targetMovieName.m4v is the name of the video to which you are 
adding the subtitles.

2 Repeat for each TTXT file.

When you have integrated all the TTXT files into the movie, drag the M4V onto the 
Dumpster icon. Double-click ‘moov’. The subtitle tracks you added to the movie can 
be found at the end of the ‘trak’ list. For example, if you added four subtitle tracks 
they will be the last four ‘trak’ entries. With this in mind...

1 Double-click the first ‘trak’ that corresponds to your first subtitle track.

2 Double-click ‘tkhd’.

3 Change Flags to $000001.

4 Click the Apply button at the bottom of the window (you must click Apply after you 
make each change described here or your changes will not be saved).

5 Change Alternate Group to $0002.

6 Double-click ‘tkhd’ to close.

7 Double-click ‘mdia’.

8 Double-click ‘hdlr’.

9 Change Component subtype to $7362746c (this will change the type to ‘sbtl’).

10 Double-click ‘hdlr’ to close.

http://www.loc.gov/standards/iso639-2/php/code_list.php
http://www.loc.gov/standards/iso639-2/php/code_list.php
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11 Repeat the above steps for each ‘trak’ that corresponds to a subtitle track, but leave 
all other ‘tkhd’/Flags set to $000000. Be sure to click the Apply button at the bottom 
of the window after you make each change. When you have finished altering all 
tracks, close Dumpster. Next, check your movie in iTunes.

1 Open the movie in iTunes.

2 Hover the pointer over the player so that the control bar appears.

3 Click the bubble icon once and you should see an alphabetical list of your subtitle 
tracks, as shown in the following image. 

4 Choose a language from the menu and the subtitles will appear at the top of the 
video region, as seen below.

5 If any subtitle tracks are missing from the menu, close iTunes, reopen the M4V in 
Dumpster and verify that you have set all the flags, groups and component subtypes 
exactly as specified above.
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6 Transfer the movie to iPhone or iPod touch. Open the movie on the iPod touch and 
tap the screen once to reveal the video controls. Tap the bubble icon; you should see 
a list of languages appear, as shown below.

7 Choose a language and tap Done.

8 Play the movie. The subtitles will appear at the bottom of the video region, as shown 
below.



Creating Accessible iTunes U Content 34

If you’re playing the movie with QuickTime Player, the subtitles can be accessed 
through the View > Subtitles menu, as shown below.
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Part 4:  Creating Audio Descriptions for iTunes Multimedia
When audio descriptions are absent from multimedia, blind or visually impaired users 
must depend on friends, family members, teachers or others to obtain relevant visual 
information from video clips. The techniques discussed in this section will show you 
how to add audio descriptions to your iTunes multimedia. Before creating your own 
descriptions, learn about iTunes-compatible audio file formats by reading “Creating 
Content for iPod + iTunes” from Apple Education.

4.1: Integration of descriptions into multimedia

Audio descriptions should be carefully written to fit into the natural pauses in the 
program dialog. In cases where a longer description is necessary but there is not a 
sufficient pause in the program audio to accommodate it, you can integrate extended 
audio descriptions into the movie. In this situation, the program dialog and video 
appear to automatically pause while a long audio description plays. When the 
description has finished playing, the video and dialog resume playback. Extended 
and “regular” descriptions may be mixed in a single multimedia presentation. You 
can watch a brief example of a video clip with regular descriptions as well as a video 
clip with extended descriptions.

When descriptions are integrated into television programs or movies, sound 
engineers are careful to lower, or “duck,” the program audio when the description is 
playing so the description can be heard clearly, and then raise the program audio 
level when the description has finished. In iTunes multimedia, ducking will only be 
possible if you use a sound-editing application to add the descriptions directly to the 
program audio track. This adds time to your production timeline but, depending on 
your goals, may be necessary if you want to produce a professional-level 
presentation. Even if you don’t duck the sound levels, you can still create an effective 
described presentation. Just note that you may have to boost the description’s sound 
level when you create and process the file to be sure it can be heard over the 
program audio. 

A final point to consider is that you need not always supply a video track with the 
described audio. The descriptions can be integrated into the movie and then the 
entire audio portion of the presentation can be saved with open descriptions and 
extracted to a separate audio file. This audio file can then be uploaded to iTunes. 
Users can download just the audio (saving both time and bandwidth) and listen to it 
on any player, including an audio-only device such as iPod shuffle.

4.2: Considerations for writing descriptions 

Ideally, describers should have excellent writing skills and a firm command of the 
vocabulary associated with the subject, as well as adequate access to reference and 
support materials, such as dictionaries, relevant textbooks, the Web, etc., in order to 
ensure that the descriptions are as clear and accurate as possible. As a final quality-
control mechanism, the descriptions should always be reviewed by someone other 
than the original writer. 

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084821091?i=1280067030
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084821091?i=1280067030
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084757097?i=1688519967
http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
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Accurately and succinctly describing visual elements poses numerous challenges. 
The Carl and Ruth Shapiro Family National Center for Accessible Media (NCAM) has 
created a set of guidelines for describing images in science textbooks and related 
materials; you’ll find helpful information there regardless of your subject matter. 
Always ensure that the descriptions convey as much information as necessary 
without being overly long. Describe all important details thoroughly, such as scenery 
and actions, scientific and mathematical expressions, or graphs and charts, and use 
a vocabulary that is appropriate to the subject matter or intended audience. 

Descriptions should be added to a presentation once the video and audio elements 
have been completed. Waiting to author descriptions until the end of the production 
process will ensure that they accurately reflect the program visuals. If you must re-
edit the video or audio after the descriptions have been created, you may have to re-
record the descriptions as well. 

If you want your described presentation to play on all devices, open descriptions are 
currently the best option. Note that iTunes, iPhone and iPod touch (OS 3.x) do, in 
fact, have the capability to toggle alternate audio tracks on and off via menus or the 
on-screen controller. QuickTime, iPod nano and Apple TV do not yet support this 
feature, although they may do so in the future. If you choose to integrate closed 
audio descriptions, you should also create a version with open descriptions so 
viewers with other playback devices can download that video and hear the described 
audio. See Part 4.8 for complete details.

Another approach to closed descriptions is to add wired sprites to toggle the 
described audio on and off, but bear in mind that these controls can only be used 
in QuickTime and iTunes (see Part 1.5). See Appendix 1 to learn about adding 
wired sprites to your presentation. 

4.3: Description method

There are a number of ways to write and record descriptions. The most 
straightforward method is to use a text processor to write a description script, then 
use QuickTime to both record the audio files and add the descriptions to the original 
video. NCAM’s free multimedia-accessibility application, MAGpie, also allows 
authors to write description scripts, record them and output them for integration with 
iTunes multimedia. See MAGpie’s documentation for complete details on usage and 
techniques for creating audio-description files. You can also use any sound-editing 
application, such as Audacity, GarageBand, Logic or Sound Forge to record the files. 
For the best results, record the descriptions in a quiet environment using a high-
quality microphone. To minimize errors or ambiguity, speak clearly and read from a 
written script. 

Here is a summary of the basic steps required for recording and integrating audio 
descriptions into iTunes multimedia. 

Watch the video and note opportunities for descriptive narration

Watch the entire presentation to determine where there are pauses in the dialog or 
narration for insertion of descriptions. This will also help you become familiar with the 
general pacing of the program material as well as the language level, vocabulary and 
knowledge the producer has assumed on the part of the viewer. While watching, 
keep notes indicating where descriptions will be inserted.

http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/logicstudio/logicpro/
http://www.apple.com/ilife/garageband/
http://audacity.sourceforge.net/
http://ncam.wgbh.org/webaccess/magpie/magpie_help/
http://ncam.wgbh.org/webaccess/magpie/index.html
http://ncam.wgbh.org/publications/stemdx/
http://ncam.wgbh.org/publications/stemdx/
http://ncam.wgbh.org/
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12 Write the descriptions

Time the pause where your first description will be inserted, then use a text editor or 
an application such as MAGpie to write the description to fit within that interval. Read 
the description while timing it to make sure it fits within the pause; edit as necessary 
and re-time. Repeat for subsequent descriptions.

Record the descriptions

Using QuickTime, MAGpie or any sound-recording software, record and edit the 
descriptions. Time them and re-record as necessary. 

Integrate the descriptions into the video

If you’re planning to integrate regular descriptions, use QuickTime to add them to the 
movie. If you’re adding extended descriptions, you’ll also need to do some video 
manipulation with QuickTime. These techniques are detailed below.

Review your work; save and upload the clip

Watch the completed movie to make sure the descriptions play at the proper points 
in the timeline, are clearly written and appropriately descriptive. If you’re using 
extended descriptions, make sure that the video stops and restarts accurately. Re-
record and re-integrate descriptions as necessary. 

4.4: Sample method of recording descriptions

The easiest way to record audio-description files is to use QuickTime. First, write the 
descriptions. When you’re ready to record them, follow the steps below.

1 Open QuickTime and choose File > New Audio Recording.

2 Plug a microphone into your computer, click the red Record button in QuickTime 
Player and make a test recording. Play it back and listen carefully to ensure your 
voice was recorded at an appropriate level relative to the program audio of the movie. 
Make adjustments as necessary until you’re happy with the quality of the audio.

3 Place a printed or electronic copy of the description script where you can easily see 
it, click the red Record button in QuickTime Player and speak into the microphone. 
When you’re finished, click the button again to stop recording.

4 Listen to the recording; re-record if necessary. When you’re satisfied with the 
recording, save the file. 

5 Record the remaining descriptions.

Any extraneous noise at the beginning and end of the audio clip—mouse or 
keyboard clicks, paper rustling, breathing, etc.—can be easily deleted. You can do 
this as you create each audio file, or you can wait until you’ve recorded them all and 
then edit them all at once.

1 Open the audio file in QuickTime.

2 Position the playhead at the beginning of the movie and press I to mark the in-point of 
the segment you’re going to cut.

3 Move the playhead to the point in the timeline immediately before you hear the 
description audio begin.
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4 Press O to mark the out-point of the segment you’re going to cut. You will see the 
segment defined in the timeline, as shown in the image below.

5 Press the Delete key to erase this segment.

6 Move the playhead to the point in the timeline immediately after the description audio 
ends and press I.

7 Move the playhead to the end of the movie and press O. You will see this new 
segment defined in the timeline, as shown below.

8 Press the Delete key to erase this segment.

9 Save the file; edit the remaining descriptions in a similar manner.

If you prefer, you can use MAGpie or any sound-editing application to record and edit 
your descriptions. No matter how you do it, it’s most efficient to record and edit all 
the descriptions before you integrate them into the video, rather than recording, 
editing and integrating the files one at a time. 

4.5: Adding open descriptions to video: full-mix audio

Once you’ve recorded and edited the descriptions, you’re ready to make them part of 
the movie that will eventually be uploaded to iTunes U. Again, the most 
straightforward method is to use QuickTime.

1 Open the original, undescribed movie in QuickTime, then choose Window > Show 
Movie Properties.

2 Open the first audio-description sound file in a new QuickTime window. Select (Edit > 
Select All) and copy (Edit > Copy) the entire sound clip.

3 Switch back to the video window. Position the playhead at the end of the pause 
where the first description will go. Press the O key to mark the out-point of the 
segment.
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4 Move the playhead backwards until you reach the beginning of this pause. Press the I 
key to mark the in-point of the segment. This selects the segment of the movie clip 
that will receive the audio description. You’ll see something similar to the image 
below.

5 Choose Edit > Add to Movie. In the track list at the top of the Movie Properties 
window, you will see that “Sound Track 2” is now one of the choices.

6 Play the clip to hear the narration you’ve just inserted. If you want, you can undo the 
insertion by choosing Edit > Undo (or delete Sound Track 2 from the track list in 
Movie Properties) and try again.

7 When you’re happy with the description, choose File > Save As, rename the clip and 
save the file as a self-contained movie.

8 Repeat steps 2-6 to insert subsequent audio descriptions. Always remember to select 
the segment that will contain the audio description by first defining the end point and 
then the beginning point. 

9 When all the descriptions have been added to the movie, save the file and then 
choose File > Export and export it as Movie to QuickTime Movie. This will combine all 
the audio tracks (the program audio plus all the descriptions) into a single track, 
giving you an open-described movie.

10 Open the exported movie in a new QuickTime window, choose File > Export, then 
choose Movie to iPod.

Your open-described movie is now ready to upload to iTunes U.
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4.6: Adding closed descriptions to video: full-mix audio

If you want to add closed descriptions to your movie, one method is to embed both 
undescribed and described program audio tracks, then add wired sprites to switch 
between the two tracks (see Appendix 1) . Note that wired sprites will only work in 
iTunes and QuickTime, not on iPhone or iPod. See Part 1.5 for more information 
before you proceed. 

1 Create an open-described movie as outlined in Part 4.5. 

2 Choose Window > Show Movie Properties.

3 From the track list, click the audio track once, then click the Extract button. The 
extracted audio track will open in a new QuickTime window.

4 Select (Edit > Select All) and copy (Edit > Copy) the entire audio track.

5 Open the original, undescribed movie in QuickTime. 

6 Make sure the playhead is positioned at the beginning of the timeline, then choose 
Edit > Add to Movie. 

7 Choose Window > Show Movie Properties. In the track listing, you will see that 
“Sound Track 2” has been added to the list. Double-click this track and rename it 
(e.g., audiodesc).

8 Choose File > Save As and save the file as a self-contained movie.

9 Add wired sprits as described in Appendix 1 to switch between the undescribed and 
described tracks.

4.7: Adding closed descriptions to video: description-only track

If you don’t want to embed two full audio tracks in your movie, you can instead 
create a track that contains only descriptions with periods of silence between each 
one, with the silence corresponding to portions of the program audio where the 
descriptions do not play. In other words, your movie will contain one track of program 
audio with no descriptions, and one track of descriptions with no program audio, both 
playing in parallel. You can then add a wired sprite as described in Appendix 1 to 
toggle the description track on and off, giving users a choice between hearing the 
descriptions or not. Read Part 1.5 before using wired sprites.

For this process, in addition to QuickTime, you’ll need a sound-editing application 
such as Audacity, GarageBand, Logic or Sound Forge. Using the sound editor, you’ll 
simultaneously listen to the program audio track while recording descriptions into a 
new track, as described below. All sound editors are different; this information 
represents a general approach to recording a separate description track rather than 
one that applies to a specific editor. For information on file formats and how to 
prepare audio files for iTunes, see “Creating Content for iPod + iTunes.”

1 Write the descriptions and place a printed or electronic copy of the description script 
where you can easily see it.

2 Open the original, undescribed video in QuickTime.

3 Choose Window > Show Movie Properties.

4 From the track list, click Program Sound once, then click the Extract button. This 
program audio track will open in a new QuickTime window.

5 Save this new audio track as a self-contained file, close its window and then open 
this track in a sound editor. 

http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/logicstudio/logicpro/
http://www.apple.com/ilife/garageband/
http://audacity.sourceforge.net/
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6 Open a new (empty) track in the sound editor, and position it so you can easily see 
both it and the program audio track.

7 Configure your editor to allow you to simultaneously listen to and record tracks. Set 
up your microphone and prepare to record your voice into the empty audio track. To 
prevent a feedback loop from occurring while you record, you’ll need to listen to the 
program audio track through headphones, not speakers.

8 Play the program audio and, at the appropriate points in the timeline and without 
pausing the program audio playback, record the audio descriptions into the empty 
track. Don’t worry about extraneous noise between descriptions (breathing, paper 
shuffling, etc.)—you’ll eliminate this in step 10, below.

9 If you make a mistake, you don’t have to re-record the entire description track. Just 
pause the playback, move the cursor back in the timeline to a point just prior to the 
faulty description, click Play and re-record the description as described in step 8.

10 When you’re finished recording, flatten the soundwaves in the intervals between the 
descriptions, thereby creating dead silence between the description audio. In most 
editors this is accomplished by selecting the interval, then lowering the audio level to 
zero. You can also replace the interval with silence, if the editor gives you this option.

11 Trim the length of the description track to exactly match the program audio track.

12 Save the description track and close the sound editor.

13 Open the description track in QuickTime, then select and copy the entire track.

14 Switch to the window containing the original, undescribed movie. 

15 Make sure the playhead is positioned at the beginning of the movie, then choose Edit 
> Add to Movie. 

16 Choose Window > Show Movie Properties. In the track list, you will see that “Sound 
Track 2” has been added to the list. Double-click this track and change the name 
(e.g., audiodesc).

17 Save the file as a self-contained movie.

18 Add a wired sprite to toggle the description track on and off (see Appendix 1).

4.8: Adding closed descriptions that are accessible using system 
menus

iTunes, iPhone and iPod touch (OS 3.x) accommodate the inclusion of extra audio 
tracks in movies, and these tracks can be used to deliver audio in alternate 
languages. When properly labeled and integrated in the movie, these tracks can be 
turned on and off via menus or with the on-screen controller, providing a convenient 
method to access closed audio descriptions. Please note that some other playback 
methods—QuickTime Player, iPod nano and Apple TV—do not currently provide a 
way to access extra audio tracks although they may do so in the future. If you 
choose to integrate closed audio descriptions, you should also create a version with 
open descriptions so viewers with other playback devices can download that video 
and hear the described audio. Watch a brief video with closed descriptions that can 
be accessed using iTunes, iPhone or iPod touch.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2254367211?i=1101365952
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2254367211?i=1101365952
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To add closed-description tracks, first record the descriptions as described in Part 
4.4, then integrate open descriptions into the video using the method described in 
Part 4.5. When you’ve finished adding the descriptions, follow the instructions below.

1 Open the original, undescribed video in QuickTime. Choose File > Export, then 
choose Movie to iPod. Close the original video, then open the newly exported video 
in a new QuickTime window. Set this window aside.

2 In QuickTime, open the video containing the open-described track. 

3 Choose Window > Show Movie Properties. Click the audio track once to highlight it, 
as shown in the following image, then click the Extract button in the upper-left corner 
of the window. 

4 The extracted audio track will open in a new QuickTime window. Select (Edit > Select 
All) and copy (Edit > Copy) the entire sound clip.

5 Switch to the undescribed video and choose Window > Show Movie Properties. In the 
player window, position the playhead at the beginning of the timeline, then choose 
Edit > Add to Movie to add the audio track with descriptions to the movie.

6 In the Show Movie Properties window, double-click each of the audio tracks and 
rename them with names that reflect their content: e.g., “Audio without descriptions” 
and “Audio with descriptions.” 
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7 Uncheck the track that contains the descriptions, as shown below, and ensure that 
the undescribed track is checked. This will make the undescribed track the default 
audio when the movie is played.

8 Click the undescribed audio track, then click the Other Settings button. From the 
Language pop-up menu, choose English. From the Alternate pop-up menu, choose 
the track with descriptions, as shown in the image below.
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9 Click the described audio track, then click the Other Settings button. From the 
Language pop-up menu, choose English. From the Alternate pop-up menu, choose 
the track without descriptions.

10 Close the Show Movie Properties window and save the file as a self-contained movie. 
(It will be saved with the MOV file extension, but it will still be playable on iPhone or 
iPod.)

11 Check your work by opening the movie in iTunes. Choose Controls > Audio & 
Subtitles. You will see the two audio tracks listed in the submenu, as shown below. 
The undescribed track will be the default. To switch to the described track, simply 
choose it from the menu.

Alternatively, roll the pointer over the video window to reveal the playback controls. 
Click the balloon image once and choose a track from the list, as shown below.
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12 To check the video on iPhone or iPod touch, sync the device with iTunes and then 
open the movie. Tap the screen to reveal the controls, then tap the alternate-
language balloon that is visible on the left edge, as seen below.

13 Choose the audio track from the Language menu, seen in the image below, then tap 
Done.

4.9: Embedding extended descriptions in video

In cases where a lengthy description is necessary but there is not a sufficient pause 
in the program audio to accommodate it, consider using extended audio 
descriptions. In this situation, the video and program audio will appear to 
automatically pause while a long audio description plays. (Note that you’re not 
actually pausing the video—instead, you’re playing a still-frame for the duration of 
the extended description.) When the description has finished playing, the video and 
program audio resume playback. Extended descriptions are open—that is, everyone 
will hear them. The process for integrating them into a movie is explained below. 

1 Record and edit the extended descriptions. You can use QuickTime (see Part 4.4) or 
any other sound-recording application.

2 Open the first extended description in QuickTime and set this window aside.
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3 In a new QuickTime window, open the original, undescribed movie.

4 Move the playhead to the exact point in the movie where you want the video to pause 
and the first extended description to play.

5 Choose File > Export, choose Movie to Picture from the Export list and choose 
Uncompressed from the Use list. This will export the single frame that is currently in 
view. Give the frame a name and click Save.

6 In a new QuickTime window, open the image file you created in step 5. 

7 Select (Edit > Select All) and copy (Edit > Copy) the entire track.

8 Switch to the window containing the first description. Choose Edit > Select All.

9 Choose Edit > Add To Selection & Scale. This will add the still frame to the entire 
description track.

10 Move the playhead to the beginning of the timeline, choose File > Save As and save 
the combined sound/image file as a self-contained movie. Select (Edit > Select All) 
and copy (Edit > Copy) the entire track.

11 Switch back to the window containing the original, undescribed movie. Assuming the 
playhead has not been moved since the image was exported, choose Edit > Paste. 
(If the playhead has moved, reposition it at the exact point in the timeline where you 
exported the frame.)

12 Play the movie. When the first extended description begins to play, the video will 
appear to pause; when the description is done playing, video playback will resume. 
Choose File > Save As and save the clip as a self-contained movie.

13 Move the playhead to the next spot in the timeline where an extended description is 
required. Repeat steps 4-11 to insert the remaining description files.

14 After all the descriptions have been added, choose File > Export and export the file 
as Movie to QuickTime Movie. This will combine all the audio tracks into a single 
track, giving you an open-described movie.

15 Open the newly exported movie in QuickTime, choose File > Export, then choose 
Movie to iPod.

Your movie with extended descriptions is now ready to upload to iTunes U.
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Part 5:  Creating Accessible iTunes U Documentation
iTunes allows you to upload not just audio and video materials; it also supports the 
use of PDF documentation. Screen readers are especially affected by the way in 
which a PDF is created, and a PDF that hasn’t been made accessible can be difficult 
or impossible for a blind or visually impaired user to navigate. This section will outline 
the steps necessary to ensure that the PDFs you create are as accessible as 
possible.

A screen reader doesn’t actually read the PDF directly from the screen; instead, it 
reads from the code. In a PDF document, this code is represented by tags, which in 
turn represent the structure and content of the document itself. If you’re familiar with 
HTML, you’ll understand PDF tags very quickly. 

As in HTML, every element of a PDF must be identified, or tagged—for example, text 
can be tagged as a paragraph, a heading, a list, etc. Image tags allow authors to 
include text alternatives, and background or unimportant images can be tagged so 
they are hidden from screen readers. Data tables can also be marked up in a 
manner that makes them usable by assistive technology. Generally speaking, if a 
PDF is tagged properly, most assistive technology will be able to navigate and 
read it. 

Ensuring proper reading order is another aspect of creating an accessible PDF. 
Reading order is represented by tags in the tag tree. The process of converting the 
source document to PDF will usually result in a satisfactory reading order, but there 
will be cases where you’ll need to re-order the tags somewhat to present information 
so it makes the most sense to someone who can’t see the screen. 

A properly tagged PDF is useful for visual users, too, because tags permit the 
document to be reflowed for small screens or viewer windows. In a reflowed 
document, text and other elements do not have to be scrolled horizontally, even 
when the window dimensions change. Reflowed documents can be more easily read 
on mobile devices, for example, or on the desktop when the viewer window has been 
reduced to a small size. 

Following the techniques described in this section will greatly improve the 
accessibility of your PDF documentation, but you must always check your work with 
a screen reader before uploading it to iTunes. Learning to use a screen reader will 
not only thoroughly test the structure of the file, it will help you navigate the 
document in a manner similar to a reader who actually uses assistive technology: if 
you can read the document accurately, chances are a blind or visually impaired user 
will be able to do so as well. Mac OS X comes with its own screen reader, 
VoiceOver. Popular Windows screen readers include JAWS and Window-Eyes; you 
can download demonstration software before you buy. 

http://www.gwmicro.com/
http://www.freedomscientific.com/
http://www.apple.com/accessibility/voiceover/
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5.1: Tools for creating accessible source documents

The guidelines below will provide a basic framework for preparing accessible source 
documents and PDFs. Before beginning, learn more about PDF accessibility from 
Adobe’s Accessibility Resource Center, and by downloading resources and tutorials 
from Adobe’s   A  ccessibility Training Resources  , including documents pertaining to 
Acrobat 8 and 9. Additionally, the book Web Accessibility: Web Standards and 
Regulatory   Compliance   has a chapter that covers many aspects of making 
accessible PDFs.

To create an accessible PDF, you’ll need the following software:

• Adobe Acrobat 9 Pro  

• Adobe Reader  

• An application that will export tagged PDFs. See the discussion below for more 
information. 

• A screen reader to test your work, as described above

No source-to-PDF conversion software, built-in or third-party, will always create a 
completely accessible PDF document at the push of a button, but how well you 
author the source file will have a big impact on how much work you’ll have to do after 
the conversion in order for the document to be as accessible as possible. No matter 
what application you use to create the source document, Adobe Acrobat Pro is 
required to complete the process of making your document accessible. You can also 
use Acrobat to add accessibility enhancements to PDFs for which no source 
documents exist. See Part 5.3 for details.

Some applications, such as OpenOffice, Word for Windows and InDesign, come with 
built-in capabilities to export tagged PDF. HTML can also be converted to PDF. 
When you install Acrobat, it installs an add-in called PDFMaker into Word (and other 
Office applications), making it easier to create and export accessible PDFs from 
those source documents. (You’ll find more information about using Word to export 
tagged PDF in the Adobe Acrobat 9 Accessibility Guide.) 

For this demonstration we’ll use Writer, part of the OpenOffice suite, to create the 
source document. Writer exports tagged PDF from both Mac and Windows, and it 
has other features to help you create documents that will successfully convert to 
accessible PDFs. It can also import documents created in other formats, including 
Word. 

http://www.openoffice.org/
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/products/acrobat/
http://get.adobe.com/reader/
http://www.adobe.com/products/acrobat/
http://www.friendsofed.com/book.html?isbn=1590596382
http://www.friendsofed.com/book.html?isbn=1590596382
http://www.friendsofed.com/book.html?isbn=1590596382
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/accessibility/
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5.2: Creating source documents that will convert to accessible PDF

Here are the basic steps for creating source documents that will translate into 
accessible PDFs.

1 Configure the source application to export tagged PDF.

Most applications are by default set to export untagged PDFs. In Writer, you can 
default to a tagged export by choosing File > Export as PDF, then checking the 
Tagged PDF box, as shown below.

2 Structure the document using styles, not just by formatting text.

Rather than highlighting text and manually altering the formatting, create and apply 
styles to format your document (just as you would in HTML). For example, create 
styles for each heading level (naming then Heading 1, Heading 2, etc., but not H1, 
H2, etc.) and apply them each time you add a heading to your document. Or, if 
you’re using data tables, create a table-header style and a table-contents style. This 
will not only visually distinguish the header cells from the data cells; Writer will export 
<TH> and <TD> cells in the tagged PDF, which the screen reader can use to help 
the user navigate and understand the table.
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Writer comes with a long list of default styles. To use them, choose Format > Styles 
and Formatting to access the Styles panel, shown below.

Double-click the style you want to use, then start typing. Or, if you’ve already 
typed text in the document, highlight the text you want to style, then double-click a 
style from the list. (The styles you use most often will also appear in the Formatting 
toolbar.) If the default styles aren’t formatted to your liking, right-click the style 
you want to apply, choose Modify from the context menu, and change the style 
characteristics to fit your design. To create a new style, right-click anywhere in the 
Styles and Formatting panel and choose New, as shown below. 

In the Styles dialog, define the characteristics you want, give the style a name and 
click the OK button. Your new style will appear in the Styles panel as well as in the 
Formatting toolbar, so you can apply it whenever necessary.

The most commonly used styles in text documents tend to be headings, default (or 
body) text, lists, table header and table data cells. If you set up these styles before 
you start writing your document, you’ll save time by not having to apply them after 
the document has been written.
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3 Add text equivalents (i.e., alt text) to all images.

As in an HTML document, every image must contain a text equivalent, sometimes 
called alternative text or alt text. Important images should be summarized or 
described briefly (a sentence or two), and unimportant images should be tagged as 
artifacts or background so they will be ignored by assistive technology. (The latter is 
done using Acrobat Pro after you convert the file; see Part 5.3 for details.) 

In Writer, add an image to the document by choosing Insert > Picture > From File, 
then browse to the image. Once you’ve inserted the image, choose Format > Picture 
or double-click the image to see the Picture dialog. Click the Options button and type 
a description into the Alternative Text field, as shown below.

Apply a text equivalent to every image in your document. See Part 5.3 for 
information on tagging unimportant or decorative images.

Some images, especially those of a scientific or mathematical nature, can be difficult 
to describe accurately. NCAM has created a set of guidelines for describing images 
in science textbooks and related materials; you’ll find helpful information there 
regardless of your subject matter. 

4 Distinguish between header and data cells in data tables.

Data tables can be classified as simple or complex. Simple data tables generally 
have one row of headers and/or one column of headers. Complex data tables can 
have nested row/column headers, with some headers spanning multiple data cells. 

http://ncam.wgbh.org/publications/stemdx/
http://ncam.wgbh.org/publications/stemdx/
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In Writer, set up your table with the appropriate number of cells. You can use Writer’s 
default styles for table headers and contents or modify them to suit your design (see 
step 2, above). If you set up these styles before you create the table, you can just 
choose the Table Heading or Table Contents style and start typing in the appropriate 
cell. If you’ve already created a complete data table but haven’t 
yet styled it, the steps below will show you how to distinguish header cells from data 
cells.

a.  Choose Format > Styles and Formatting to open the Styles panel.

b.  Highlight the row of headers, then double-click Table Heading in the Styles panel.

c.  Highlight the column of headers and choose Table Heading.
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d.  Highlight the data cells and choose Table Contents. 

When you export the document as PDF, the table headers will appear in the tag tree 
as <TH> and the content (or data) cells will appear as <TD>; screen readers will use 
these tags to help users navigate the table. If your data table contains nested 
headers, or headers that span multiple columns or rows, just make sure that you tag 
all the headers and data cells with the appropriate header or data styles, as shown 
above. 

5 Convert the document to PDF.

After you’ve written and formatted your document, choose File > Export as PDF. 
Click the General choose and make sure the Tagged PDF box is checked. Click the 
Export button, give the file a name and click Save. 

6 Open the document in Acrobat Pro.

Using Acrobat Pro, open the newly converted PDF. You’ll always want to see the tag 
tree, so open View > Navigation Panels. Drag the Tags tab over to the dock on the 
edge of the screen so you’ll be able to easily find it later, as shown below. 
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Click Tags once and press Shift-8 to expand the entire tag tree...

...and open the Options menu in the Tags panel and choose Highlight Content, as 
shown here.

Activating Highlight Content allows you to visually associate each tag with an 
element in the document. This will come in handy later, especially when you’re 
verifying the reading order. You won’t have to drag the Tags panel to the dock every 
time you open a PDF, but you will always have to expand the tag tree and choose 
Highlight Content.
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7 Run an accessibility check.

Acrobat comes with an accessibility checker that will find common errors and tell you 
how to fix them. However, it can only check for machine-verifiable problems. For 
example, it will tell you that alt text is missing from an image, but it cannot tell you 
anything about the quality of existing alt text. It also can’t tell you if the cells of a data 
table have been correctly tagged with <TH> and <TD>. These and other items must 
be verified manually by inspecting the tags in the tag tree. 

To run an accessibility check, choose Advanced > Accessibility > Full Check. Choose 
Create Accessibility Report and Include Repair Hints. Specify Adobe PDF in the 
Checking Options area, select all the checking options and click the Start Checking 
button. If Acrobat finds errors, a report will open in the Accessibility panel. The report 
will give you details on how to correct most problems, so read it carefully and follow 
the instructions. Three common errors are covered below. 

Missing alt text

If an important image is missing alt text, correct this error in the source, not in the 
PDF, and then re-export. If an unimportant or decorative image is missing alt text, 
you can tag it in the PDF as an artifact or background so it will be ignored by a 
screen reader. See Part 5.3 for details.

Missing language specification

The language specification tells assistive technology what language to use when 
reading the document. Choose File > Document > Properties, then click the 
Advanced button. Choose the language from the list in the Reading Options area to 
set the language for the entire document.

Items missing from tag tree

Some items, frequently background images, may not get tagged during the export 
process, so you must tag the item manually. See Part 5.3 for details.

You can find more documentation about using the Acrobat accessibility checker at 
Adobe’s Accessibility Training Resources. 

8 Verify the reading order.

The reading order of the document is determined by the order of tags in the tree. It is 
quite likely that the PDF export from the source document will result in a reading 
order that is nearly correct, but occasionally some items will need to be relocated. 
Because a screen reader conveys the document data to the user by following the tag 
tree, it’s important to make sure that the tags are all in the right order. 

To verify the reading order using Acrobat, open the Tags panel, expand the tag tree 
and choose Highlight Content from the Options menu, then use the arrow keys to 
move through the tree, watching the focus in the document pane as it moves through 
the document itself. The order in which the focus moves will correspond to the order 
in which the screen reader reads the document to the user. If you see that the 
reading order is incorrect, you can drag the tag nodes around the tree into the proper 
order, or click the tag(s) you want to move and use the Cut/Paste choices in the 
Options menu. Relocating tags is not necessarily a difficult task, but you must work 
carefully because Acrobat has no undo feature for putting the tags back in their 
original locations. Save your work frequently and keep a backup copy on hand. 

http://www.adobe.com/enterprise/accessibility/training.html
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You can also alter the reading order by using the Order panel. Choose View > 
Navigation Panels > Order, and drag the Order tab into the dock on the edge of the 
screen to make it easier to find the next time you need it. You’ll see the reading order 
in both the Order panel as well in the document pane itself, as shown below.

To change the reading order of whole blocks of text, simply drag the tags around in 
the Order panel.

9 Check your work with a screen reader.

Even if Acrobat tells you that there are no accessibility errors in your PDF, you must 
always check your work with a screen reader. Mac OS X comes with its own screen 
reader, VoiceOver. Popular Windows screen readers include JAWS and Window-
Eyes; you can download demonstration software before you buy. You can learn more 
about how screen readers work by reading some fact sheets at the WebAIM site.

Open the document using Adobe Reader (not Acrobat) and read it with a screen 
reader. Better still, give the document to an experienced screen-reader user for an 
evaluation. Among other things, a screen reader will make it immediately obvious if 
the reading order is correct or if the alt tags make sense. If you find errors, correct 
them and check the document with a screen reader again. 

5.3: Creating accessible PDFs when no source document is 
available

While it’s always best to add accessibility enhancements to the source document 
before converting it to PDF, there may be times when you must work with a PDF for 
which no source document exists. In these cases, you can use Acrobat to repair the 
document and make it as accessible as possible. The basics are covered below, and 
you’ll find more information in the Adobe documents highlighted in Part 5.1.

1 Check the document for tags.

Open the document in Acrobat and then open the Tags panel (see Part 5.2, #6 for 
details). If you can see that the document has tags, you can skip to #2, below. If the 
panel says “No tags available,” you’ll need Acrobat to add them for you. Choose 
Advanced > Accessibility > Add Tags to Document. Acrobat will tag the document 
and then display a collapsed tag tree in the Tags panel. Expand the tree by pressing 
Shift+8, then choose Highlight Content from the Options menu.

http://get.adobe.com/reader/
http://www.webaim.org/articles/screenreader_testing/
http://www.webaim.org/articles/screenreader_testing/
http://www.gwmicro.com/
http://www.gwmicro.com/
http://www.freedomscientific.com/
http://www.apple.com/accessibility/voiceover/
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While Acrobat does a good job of tagging each element in the document, it doesn’t 
necessarily tag everything correctly. It will make its best guess based on the 
document’s structure and layout, but it has no way of knowing with complete 
certainty, for example, whether a heading should be tagged as a Heading 1 or a 
Heading 3, or whether cells in a table should be tagged as headers or data. And 
while it can recognize and tag an image, it cannot automatically generate alternative 
text or determine whether the image should be tagged as an artifact. 

Now that you’ve tagged the document, you’ll need to check the tags to make sure 
they accurately reflect the structure of the document. Below are some of the 
common problems encountered when tagging untagged documents. You can learn 
about other solutions by reading the tutorials at Adobe’s Accessibility Training 
Resources site.

2 Verify the reading order.

See Part 5.2, # 8, for information on checking and adjusting the reading order. 

3 Add text equivalents to images.

Acrobat will recognize and tag most images but it cannot add alternative text to 
them. You must do that yourself by following these steps.

• With the tag tree expanded, right-click an image tag (it will say “Figure”) and choose 
Properties from the context menu (or click the tag once and choose Properties 
from the Options menu). Click the Tag button and enter text in the Alternate Text 
box, as shown below. 

http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/enterprise/accessibility/training.html
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• If the image is unimportant or decorative, open the Properties window as described 
above and, in the Type field, enter “Artifact” (no quotes, capital A). You’ll see the 
tag change from Figure to Artifact in the tree. Any item tagged as an Artifact will be 
ignored by a screen reader. If you need to tag the item as a background image, 
see step 4, below.

4 Tag images as background.

If you have an image that serves as a background to text or another image, you can 
tag it so it will be ignored by screen readers. Choose Advanced > Accessibility > 
TouchUp Reading Order and move the panel to the side. Drag a rectangle around 
the item you want to tag as a background (or double-click it) and click the 
Background button, as shown in the image below.
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5 Verify or add headings.

Acrobat will tag text that it thinks is a heading with an H tag (corresponding to 
Heading 1, Heading 2, etc.). It might tag the heading levels correctly, but there’s a 
reasonable chance that it won’t because it can’t detect the context in which the 
heading appears. However, it’s a simple matter to change a heading level, or to re-
tag an incorrectly tagged heading.

• With the tag tree open, right-click a heading tag and choose Properties from the 
context menu (or click the tag once and choose Properties from the Options 
menu). Click the Tag button, and change the heading level in the Type list, as 
shown below.

• You can also re-tag headers using the TouchUp tool. Choose Advanced > 
Accessibility > TouchUp Reading Order, drag a rectangle around the text or block 
of text that should be a header and click the appropriate heading button in the 
TouchUp tool. Only Heading 1-Heading 3 are available in the tool; if you need 
levels 4-6, tag the header with the TouchUp tool, then click the tag in the tree, open 
the Properties window and change the level there. 

6 Verify data-table structure.

Acrobat will usually recognize a data table in a source document, but it probably 
won’t correctly tag the header and data cells. Manually retagging data tables will 
greatly improve the accessibility of your document.

• Choose Advanced > Accessibility > TouchUp Reading Order. If you see that Acrobat 
has correctly tagged the data table as a single table, proceed to the next step. If 
Acrobat has mistakenly tagged the table as a series of separate data tables, drag a 
box around the entire table and click the Table button in the TouchUp window. This 
will create a single data table.
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• Right-click the table and choose Table Editor, then right-click again on the table and 
choose Table Editor Options. For easy visual differentiation, change the color 
schemes for data and header cells. Also check the two Show Cell boxes, as shown 
in the image below. 

• Click OK. The color choices you specified will now be applied to the table, and the 
cells themselves will be labeled as TD or TH, as shown in the image below.

• To change a data cell to a header cell, right-click the cell and choose Table Cell 
Properties. In the dialog, change the designation to Header Cell, as shown below, 
and specify the scope (direction) of the cell.

After you’re finished, the table will look something like the one shown below.
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Repeat as necessary for the other table cells.

• You can also re-tag table cells directly in the tag tree. Right-click a <TH> or <TD> 
tag in the tag tree and choose Properties from the context menu (or click the tag 
once and choose Properties from the Options menu). Click the Tag tab, and 
choose Table Data Cell or Table Header Cell from the Type list, as shown below.

7 Run an accessibility check and verify results with a screen reader.

As discussed in Part 5.2, check your work not only with Acrobat’s accessibility 
checker but also with a screen reader. Choose Advanced > Accessibility > Full 
Check, specify the PDF options, generate a report and read it carefully, correcting 
errors as described in Part 5.2. When you’ve reduced or eliminated the errors, 
always test the document with Adobe Reader and a screen reader, verifying the 
accessibility of your document before uploading it to iTunes U.
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Appendix 1:  Adding Wired Sprites to Control 
Captions and Descriptions
QuickTime Player, iTunes, iPhone and iPod nano all provide menus or buttons to 
control SCC closed captions when they are available in a presentation (see 
Appendix 2 for details on how to access these controls). If you’re using QTText to 
integrate closed captions, you must add your own controls to the presentation if you 
want to give users the ability to turn the text on and off. The same is true for audio 
description tracks. These controls can take the form of wired sprites, which are 
QuickTime tracks that permit interactivity. There is a trade-off, however: wired sprites 
can be operated only when the movie is played using QuickTime or iTunes. A movie 
with wired sprites cannot be copied to or used on iPhone or iPod. See Part 1.5 for 
more information.

Below is a picture of caption and description controls integrated into a movie. You 
can also watch a sample video containing wired sprites that control the display of 
captions and descriptions. 

To add control elements to a QuickTime movie, you will need the following items:

• QuickTime Pro  

• A QuickTime movie with embedded captions and/or audio descriptions

• Control elements; that is, the wired sprites themselves. You can download basic 
controls for captions and descriptions from NCAM, or make your own using 
software such as LiveStage from Totally Hip. If you’re unfamiliar with building wired 
sprites, first learn about interactivity in QuickTime movies from the Apple Developer 
Connection. 

http://developer.apple.com/documentation/quicktime/IQ_InteractiveMovies/preface/QT_Interactive_preface.html
http://www.totallyhip.com/
http://ncamftp.wgbh.org/richmedia
http://ncamftp.wgbh.org/richmedia
http://www.apple.com/quicktime
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084821080?i=1842088322
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For the purposes of demonstration, the instructions below use NCAM’s pre-made 
caption-control elements, so first you should download cc_off_at_start.mov or 
cc_on_at_start.mov.

1 Open the captioned QuickTime movie.

2 Choose Window > Show Movie Properties. In the track list, make sure the caption 
track has been named “captions,” without quotes. If it has a different name, double-
click it and change the name now.

3 In a new QuickTime window, open cc_off_at_start.mov.

4 Select (Edit > Select All) and copy (Edit > Copy) the entire track.

5 Switch to the window containing the captioned movie.

6 Make sure the playhead is positioned at the beginning of the clip. Choose Edit > Add 
to Selection & Scale. The caption buttons will be added to the presentation, as shown 
below. In the Movie Properties window you will see two new tracks in the track list: 
ccoffatstart and background.

7 Click the off and on buttons to toggle the caption display. If this doesn’t work, check 
the Movie Properties window to make sure you’ve named the caption track as 
“captions.”

8 If you want to reposition the button, open the Movie Properties window. Click 
ccoffatstart in the track list, then click the Visual Settings button and enter the new 
coordinates in the Offset area. The first entry is the X (horizontal) position; the second 
entry is the Y (vertical) position. Repeat the same offset for the background track. You 
may also find that offsetting the video region (click Program Video in the track list) is 
useful.

http://ncamftp.wgbh.org/richmedia/
http://ncamftp.wgbh.org/richmedia/
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9 When the controls are positioned where you want them, make sure the text track is 
turned off by clicking the “off” button, then choose File > Save As and save the clip as 
a self-contained movie.

If you want the captions to be on when the movie begins playing, just substitute the 
file “cc_on_at_start” in step 3. After repositioning the elements and testing the 
toggles, be sure to save the movie with the captions on rather than off.

If you want to add toggles for audio descriptions instead of captions, download 
ad_off_at_start.mov or ad_on_at_start.mov instead. Then follow the instructions 
above, observing two substitutions: in step 2, name the audio-description track that 
you have embedded as “audiodesc”; in step 3, use the file ad_off_at_start.mov or 
ad_on_at_start.mov.

http://ncamftp.wgbh.org/richmedia/
http://ncamftp.wgbh.org/richmedia/
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Appendix 2:  Turning SCC Closed Captions On and 
Off
Below are instructions for turning SCC captions on and off using the controls that are 
included with many Apple multimedia players.

QuickTime Player

1 Choose View > Show Closed Captioning to reveal the captions, or View > Hide 
Closed Captioning to hide them.

2 To specify default behavior: choose QuickTime > Preferences > General, and check 
or uncheck the box next to Show Closed Captioning When Available.

iTunes

1 Method 1: open Controls > Audio & Subtitles; choose Show or Hide Closed 
Captioning.

2 Method 2: roll the pointer over the video window, click the balloon in the control bar 
and choose Show or Hide Closed Captioning.

3 To specify default behavior: choose iTunes > Preferences > Playback, and check or 
uncheck the box next to Show Closed Captioning When Available.

iPhone

Open Settings > iPod; in the Video area move the Closed Captioning slider to on or 
off.

iPod nano

Open Videos > Settings, scroll to Captions and select on or off.

iPod classic

Open Videos > Settings, scroll to Captions and select on or off.

Apple TV

Open Settings > Audio & Video, Closed Captioning, and select Off, Enhanced or 
Standard.
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Appendix 3:  Caption Support in Apple Products

Device Caption 
formats

Decode SCC 
captions?

Support wired 
sprites?

Support closed 
descriptions?

QuickTime Player for 
Mac and Windows

SCC, QTText Yes Yes Yes; requires wired 
sprite

iTunes Player for Mac 
and Windows

SCC, QTText Yes Yes Yes; uses menus or 
on-screen controller

iPhone, iPod touch SCC, QTText Yes No Yes; uses on-screen 
controller

iPod nano SCC, QTText Yes No No; only plays open 
descriptions

iPod shuffle None No No No; only plays open 
descriptions

iPod classic SCC, QTText Yes No No; only plays open 
descriptions

Apple TV SCC, QTText Yes No No; only plays open 
descriptions

http://www.apple.com/appletv/
http://www.apple.com/ipodclassic/
http://www.apple.com/ipodshuffle/
http://www.apple.com/ipodnano/
http://www.apple.com/iphone/
http://www.apple.com/itunes/
http://www.apple.com/itunes/
http://www.apple.com/quicktime
http://www.apple.com/quicktime
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Appendix 4:  Closed Captioning and Audio 
Description Resources 

Major captioning service providers include:

Media Access Group at WGBH 

WGBH Educational Foundation 
1 Guest Street
Boston, MA 02135 
Voice/TTY: (617) 300-3600 
Fax: (617) 300-1020
e-mail: access@wgbh.org

National Captioning Institute

1900 Gallows Rd., Suite 3000 
Vienna, VA 22182 
Voice/TTY: (703) 917-7600 
Fax: (713) 917-9878 

VITAC 

101 Hillpointe Dr. 
Canonsburg, PA 15317-9503 
Phone: (800) 278-4822 
Fax: (724) 514-4111

A directory of captioning service providers is also available from the Closed 
Captioning Web.

Audio description service providers include:

Media Access Group at WGBH 

WGBH Educational Foundation 
1 Guest Street
Boston, MA 02135 
Voice/TTY: (617) 300-3600 
Fax: (617) 300-1020
e-mail: access@wgbh.org

CaptionMax

2438 27th Avenue South 
Minneapolis, MN 55406 
Phone: (612) 341-3566 
Fax: (612) 341-2345 

Narrative Television Network 

5840 South Memorial Dr., Suite 312 
Tulsa, OK 74145-9082 
Phone: (918) 627-1000 
Fax: (918) 627-4101 

http://www.narrativetv.com/
http://www.captionmax.com/
mailto:access@wgbh.org
http://access.wgbh.org/
http://www.captions.org/
http://www.captions.org/
http://www.captions.org/services.cfm
http://www.vitac.com/
http://www.ncicap.org/
mailto:access@wgbh.org
http://access.wgbh.org/
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Appendix 5:  General Resources 

Regulations and guidelines

• Section 508 Guidelines  

Section 508 requires electronic and information technology developed, procured, 
maintained or used by Federal agencies to be accessible to people with disabilities. 
This includes Web sites and multimedia.

• Web Content Accessibility Guidelines 2.0  

Complete recommendations from the Web Accessibility Initiative at the World Wide 
Web Consortium (WAI/W3C) for making Web and multimedia content more 
accessible to people with disabilities.

• IMS Guidelines for Developing Accessible Learning Applications  

Guidelines developed by the IMS Accessibility Project Group to provide a framework 
for the distributed-learning community. 

• Accessible Digital Media  

Accessibility guidelines from the Carl and Ruth Shapiro Family National Center for 
Accessible Media (NCAM) focusing on solutions for accessible multimedia.

• Effective Practices for Description of Science Content within Digital Talking Books  

Image-description guidelines from NCAM focusing on science, technology, 
engineering and math content.

Accessible PDF

• Adobe’s Accessibility Resource Center  

General information and documentation about accessibility efforts at Adobe.

• Adobe’s Accessibility Training Resources  

Documentation and tutorials relating to the accessibility features of Acrobat 8 and 9. 

• Web Accessibility: Web Standards and Regulatory Compliance   

Book about Web accessibility, including a chapter covering PDF accessibility.

• PDF Accessibility at WebAIM  

Techniques for creating accessible PDF materials.

Accessibility at Apple

• Apple’s Accessibility Homepage  

Information about Apple’s accessibility efforts as they relate to hardware and 
software.

• VoiceOver  

Details about the built-in screen reader for Mac OS X and iPhone 3GS.

• Mac OS X  

Information about the accessibility features built into Mac OS X.

Other screen readers

• Windows-Eyes  

http://www.gwmicro.com/
http://www.apple.com/accessibility/macosx/vision.html
http://www.apple.com/accessibility/voiceover/
http://www.apple.com/accessibility/
http://www.webaim.org/techniques/acrobat/
http://www.friendsofed.com/book.html?isbn=1590596382
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/accessibility/
http://ncam.wgbh.org/publications/stemdx/intro.html
http://ncam.wgbh.org/publications/adm/
http://ncam.wgbh.org/salt/guidelines/
http://www.w3.org/TR/2008/REC-WCAG20-20081211/
http://section508.gov/index.cfm?FuseAction=Content&ID=12#Web
http://section508.gov/index.cfm?FuseAction=Content&ID=12
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The recommended screen reader for iTunes U on Windows

• JAWS  

Popular screen readers for Windows. Demonstration copies are available.

• Orca (linux)  
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